hard clutch

Keeping you informed of what's happening with the forum, updates, downtime etc.
Post Reply
jzape2005
Posts: 51
Joined: Sun Sep 29, 2013 5:12 pm

hard clutch

Post by jzape2005 »

Hello, I apologize, if it is not the correct section. I explain a little my problem, after doing about 100km, the clutch becomes very hard, the lever is difficult to operate, I end up with the painful hand of using it, any help? thanks from Catalonia, Spain.Image

Enviat des del meu Redmi S2 usant Tapatalk


User avatar
sirch345
Site Admin
Posts: 18638
Joined: Mon Aug 25, 2003 9:35 pm
Location: Cornwall, UK

Re: hard clutch

Post by sirch345 »

I would start by removing the clutch lever (by removing that it stops the slave cylinder piston being pushed out), then remove the front sprocket cover with clutch slave cylinder still attached to it, suspend it up out of the way leaving the hose still attached. See if that needs a good clean in behind there and while your are there remove the clutch push rod and check it's not bent, give that clean and lubrication before refitting.

Chris.
A closed mouth gathers no foot. :thumbup:

jzape2005
Posts: 51
Joined: Sun Sep 29, 2013 5:12 pm

Re: hard clutch

Post by jzape2005 »

okay. Thanks for your time. I have reviewed the clutch pump, it seems that it is fine, the lever is fine, there are no strange friction, I need to look at the hydraulic piston that goes in the engine and the rod that acts in the clutch, to see if I can this end of week, a greeting and thanks, I will report what you see when disassembling.

User avatar
sirch345
Site Admin
Posts: 18638
Joined: Mon Aug 25, 2003 9:35 pm
Location: Cornwall, UK

Re: hard clutch

Post by sirch345 »

The hydraulic piston that goes in the engine as you say is what we call the "Slave cylinder" The clutch pump you have reviewed we call the "Master cylinder".

Just remember to remove the clutch lever at the handlebars before removing the sprocket cover and slave cylinder,

Chris.
A closed mouth gathers no foot. :thumbup:

jzape2005
Posts: 51
Joined: Sun Sep 29, 2013 5:12 pm

Re: hard clutch

Post by jzape2005 »

I hope excuse my English, it is quite bad, the translators too, it must be difficult for you to understand my words.
I am grateful for your patience, greetings

User avatar
sirch345
Site Admin
Posts: 18638
Joined: Mon Aug 25, 2003 9:35 pm
Location: Cornwall, UK

Re: hard clutch

Post by sirch345 »

jzape2005 wrote: ↑
Thu Jul 09, 2020 9:56 pm
I hope excuse my English, it is quite bad, the translators too, it must be difficult for you to understand my words.
I am grateful for your patience, greetings
:) providing you can understand my words then all is good :thumbup:

Chris.
A closed mouth gathers no foot. :thumbup:

jzape2005
Posts: 51
Joined: Sun Sep 29, 2013 5:12 pm

Re: hard clutch

Post by jzape2005 »

:thumbup: :thumbup:

jzape2005
Posts: 51
Joined: Sun Sep 29, 2013 5:12 pm

Re: hard clutch

Post by jzape2005 »

sirch345 wrote:
jzape2005 wrote: ↑
Thu Jul 09, 2020 9:56 pm
I hope excuse my English, it is quite bad, the translators too, it must be difficult for you to understand my words.
I am grateful for your patience, greetings
:) providing you can understand my words then all is good Image

Chris.
Hello, I think I have found the problem. I have removed the clutch lever, cleaned and reviewed, the tube that goes to the slave cylinder is rubber, it seems that over the years it has deteriorated. I have bought a new line and will install it when it arrives from U.K. I will comment on the result when I install it. A greeting.

Enviat des del meu Redmi S2 usant Tapatalk


Dickiebig
Posts: 621
Joined: Sun Nov 22, 2015 12:19 pm
Location: Gloucester

Re: hard clutch

Post by Dickiebig »

Best of luck, I hope it goes in ok.
The bleeding of has a reputation for being a bugger, but there is lots of advice on the best way, so crack on πŸ‘πŸ˜„πŸ˜„πŸ˜„πŸ‘πŸ‘πŸ˜·

User avatar
sirch345
Site Admin
Posts: 18638
Joined: Mon Aug 25, 2003 9:35 pm
Location: Cornwall, UK

Re: hard clutch

Post by sirch345 »

jzape2005 wrote: ↑
Wed Jul 15, 2020 10:22 am
sirch345 wrote:
jzape2005 wrote: ↑
Thu Jul 09, 2020 9:56 pm
I hope excuse my English, it is quite bad, the translators too, it must be difficult for you to understand my words.
I am grateful for your patience, greetings
:) providing you can understand my words then all is good Image

Chris.
Hello, I think I have found the problem. I have removed the clutch lever, cleaned and reviewed, the tube that goes to the slave cylinder is rubber, it seems that over the years it has deteriorated. I have bought a new line and will install it when it arrives from U.K. I will comment on the result when I install it. A greeting.

Enviat des del meu Redmi S2 usant Tapatalk
Hello, I'm glad you have found a possible cause of this problem :D

I hope the new clutch line will fix it,

Chris.
A closed mouth gathers no foot. :thumbup:

jzape2005
Posts: 51
Joined: Sun Sep 29, 2013 5:12 pm

Re: hard clutch

Post by jzape2005 »

sirch345 wrote:
jzape2005 wrote: ↑
Wed Jul 15, 2020 10:22 am
sirch345 wrote: :) providing you can understand my words then all is good Image

Chris.
Hello, I think I have found the problem. I have removed the clutch lever, cleaned and reviewed, the tube that goes to the slave cylinder is rubber, it seems that over the years it has deteriorated. I have bought a new line and will install it when it arrives from U.K. I will comment on the result when I install it. A greeting.

Enviat des del meu Redmi S2 usant Tapatalk
Hello, I'm glad you have found a possible cause of this problem :D

I hope the new clutch line will fix it,

Chris.
Hola, eso espero Chris, de momento paciencia hasta que Royal Mail me envie el pedido.
Mi mano lo agradecera, la ultima ruta fue dura para ella

Enviat des del meu Redmi S2 usant Tapatalk


jzape2005
Posts: 51
Joined: Sun Sep 29, 2013 5:12 pm

Re: hard clutch

Post by jzape2005 »

jzape2005 wrote:
sirch345 wrote:
jzape2005 wrote: ↑
Wed Jul 15, 2020 10:22 am
Hello, I think I have found the problem. I have removed the clutch lever, cleaned and reviewed, the tube that goes to the slave cylinder is rubber, it seems that over the years it has deteriorated. I have bought a new line and will install it when it arrives from U.K. I will comment on the result when I install it. A greeting.

Enviat des del meu Redmi S2 usant Tapatalk
Hello, I'm glad you have found a possible cause of this problem :D

I hope the new clutch line will fix it,

Chris.
Hola, eso espero Chris, de momento paciencia hasta que Royal Mail me envie el pedido.
Mi mano lo agradecera, la ultima ruta fue dura para ella

Enviat des del meu Redmi S2 usant Tapatalk
Hello, I hope so Chris, for the time being patience until Royal Mail sends me the order. My hand will thank you, the last route was hard for her

Enviat des del meu Redmi S2 usant Tapatalk


Dickiebig
Posts: 621
Joined: Sun Nov 22, 2015 12:19 pm
Location: Gloucester

Re: hard clutch

Post by Dickiebig »

I feel your pain! I used to own a Laverda! πŸ˜‚πŸ˜‚

Post Reply